注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

往事如烟

科技创造价值

 
 
 

日志

 
 

原创:锐捷S3750系列交换机基本配置实例  

2010-01-29 15:58:28|  分类: 网络管理 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

一、基础管理
    在网络设备的首次使用时只能使用串口(Console)方式连接网络设备,称为带外(Outband)管理方式。在进行了相关配置后,可以通过 Telnet  虚拟终端方式连接和管理网络设备。通过这两者都可以访问命令行界面。
    将交换机的控制口与PC的com1口连接,启动超级终端,连接时使用COM1,COM1属性还原为默认值,打开交换机电源启动交换机。
Ruijie>enable   //进入特权模式
Password:       //输入口令
Ruijie#

1、查看系统信息

Ruijie#show version    //显示系统版本信息
Ruijie#show version devices   //显示设备硬件信息
Ruijie#show version slots   //显示设备插槽和模块信息
2、配置控制台登录口令
Ruijie#configure terminal   //进入全局配置模式
Enter configuration commands, one per line. End with CNTL/Z.

Ruijie(config)#line console 0   //进入控制台线路模式(有aux、console、tty、vty四种线路模式),0是控制台的线路编号
Ruijie(config-line)#password 8888  
//设置line线路口令8888
Ruijie(config-line)#login   //启用line线路口令保护
Ruijie(config-line)#exit   //回到全局配置模式
3、配置Telnet登录口令
Ruijie(Config)#enable service telnet-server   //启用Telnet服务
Ruijie(config)#line vty 0 4   //进入vty线路模式(有aux、console、tty、vty四种线路模式),0~4是Telnet登录的线路编号共5个
Ruijie(config-line)#transport input telnet   //配置vty线路模式下允许的通信协议Telnet(有all、ssh、telnet、none)
Ruijie(config-line)#password 8888   //设置line线路口令8888
Ruijie(config-line)#login   //启用line线路口令保护
Ruijie(config-line)#exit   //回到全局配置模式
4、配置特权模式口令
Ruijie(config)#enable password 8888   //创建一个缺省为15级(最高授权级别)的静态口令8888
Ruijie(config)#enable secret 8888   //创建一个缺省为15级(最高授权级别)安全口令8888(与上一条命令二选一)
Ruijie(config)#end   //回到特权模式

二、配置接口和VLAN
1、配置物理接口
Ruijie#show version slots   //显示设备插槽和模块信息
Ruijie#configure terminal    //进入全局配置模式
Enter configuration commands, one per line. End with CNTL/Z.
Ruijie(config)#interface range fastethernet 0/1-24   //进入接口配置模式配置0/1-0/24接口
Ruijie(config-if-range)#medium-type copper   //设置接口介质为铜缆(双绞线)接口(fiber为光纤接口)
Ruijie(config-if-range)#speed auto   //设置接口的速率为自协商(有10、100、1000、auto)
Ruijie(config-if-range)#duplex full   //
设置接口的双工模式为全双工(有auto、full、half)
Ruijie(config-if-range)#flowcontrol auto   //设置接口的流控模式为自协商(有auto、on、off)
Ruijie(config-if-range)#no shutdown   //重新打开此接口
Ruijie(config-if-range)#exit   //回到全局配置模式
Ruijie(config)#interface range gigabitethernet 0/25-27   //进入接口配置模式配置0/25-0/27接口
Ruijie(config-if-range)#medium-type fiber   //设置接口介质为光纤接口(copper为铜缆接口)
Ruijie(config-if-range)#speed 1000   //设置接口的速率为1000M(有10、100、1000、auto)
Ruijie(config-if-range)#duplex full   //设置接口的双工模式为全双工(有auto、full、half)
Ruijie(config-if-range)#flowcontrol auto   //设置接口的流控模式为自协商(有auto、on、off)
Ruijie(config-if-range)#no shutdown   //重新打开此接口
Ruijie(config-if-range)#exit   //回到全局配置模式
Ruijie(config)#interface gigabitethernet 0/28   //进入接口配置模式配置0/28接口
Ruijie(config-if-GigabitEthernet 0/28)#medium-type copper   //设置接口介质为铜缆(双绞线)接口(fiber为光纤接口)
Ruijie(config-if-GigabitEthernet 0/28)#speed auto   //设置接口的速率为自协商(有10、100、1000、auto)
Ruijie(config-if-GigabitEthernet 0/28)#duplex full   //设置接口的双工模式为全双工(有auto、full、half)
Ruijie(config-if-GigabitEthernet 0/28)#flowcontrol auto   //设置接口的流控模式为自协商(有auto、on、off)
Ruijie(config-if-GigabitEthernet 0/28)#no shutdown   //重新打开此接口
Ruijie(config-if-GigabitEthernet 0/28)#end   //回到特权模式

Ruijie#show interfaces   //显示接口全部信息
2、配置二层接口(Access Port)

Ruijie#
configure terminal    //进入全局配置模式
Enter configuration commands, one per line. End with CNTL/Z.
Ruijie(config)#interface range fastethernet 0/1-24   //进入接口配置模式配置0/1-0/24接口
Ruijie(config-if-range)#switchport mode access   //配置此接口的二层模式为交换端口(trunk为中继端口)
Ruijie(config-if-range)#exit   //回到全局配置模式
Ruijie(config)#interface range gigabitethernet 0/25-27   //进入接口配置模式配置0/25-0/27接口
Ruijie(config-if-range)#switchport mode access   //配置此接口的二层模式为交换端口(trunk为中继端口)
Ruijie(config-if-range)#end   //回到特权模式
Ruijie#show interface switchport   //显示可交换端口(非路由端口)信息

3、配置VLAN
Ruijie#
configure terminal    //进入全局配置模式
Enter configuration commands, one per line. End with CNTL/Z.
Ruijie(config)#vlan 2   //创建vlan 2(已存在默认vlan 1)并进入vlan配置模式
Ruijie(config-vlan)#exit   //回到全局配置模式
Ruijie(config)#vlan 3   //创建vlan 3并进入vlan配置模式
Ruijie(config-vlan)#exit   //回到全局配置模式
Ruijie(config)#vlan 4   //创建vlan 4并进入vlan配置模式
Ruijie(config-vlan)#exit   //回到全局配置模式
Ruijie(config)#interface gigabitethernet 0/27   //配置0/27端口
Ruijie(config-if-Gigabitethernet 0/27)#switchport access vlan 1   //将接口分配给VLAN 1
Ruijie(config-if-Gigabitethernet 0/27)#exit   //回到全局配置模式
Ruijie(config)#interface range gigabitethernet 0/25-26   //配置0/25-0/26端口
Ruijie(config-if-range)#switchport access vlan 2   //将接口分配给VLAN 2
Ruijie(config-if-range)#exit   //回到全局配置模式
Ruijie(config)#interface range fastethernet 0/19-24   //配置0/19-0/24端口
Ruijie(config-if-range)#switchport access vlan 3   //将接口分配给VLAN 3
Ruijie(config-if-range)#exit   //回到全局配置模式
Ruijie(config)#interface range fastethernet 0/1-18   //配置0/1-0/18端口
Ruijie(config-if-range)#switchport access vlan 4   //将接口分配给VLAN 4
Ruijie(config-if-range)#end   //回到特权模式
Ruijie#show vlan   //显示vlan信息
4、配置三层接口(RoutePort和SVI)
Ruijie#configure terminal   //进入全局配置模式 
Enter configuration commands, one per line. End with CNTL/Z.
Ruijie(config)#interface gigabitethernet 0/28   //配置0/28接口
Ruijie(config-if-Gigabitethernet 0/28)#no switchport    //将此接口转换成三层模式(默认为二层access模式) 
Ruijie(config-if-Gigabitethernet 0/28)#ip address 10.1.252.26 255.255.255.0     //配置IP地址10.1.252.26子网掩码255.255.255.0
Ruijie(config-if-Gigabitethernet 0/28)#no shutdown   //重新打开此接口
Ruijie(config-if-Gigabitethernet 0/28)#exit   //回到全局配置模式
Ruijie(config)#interface vlan 1   //配置vlan 1
Ruijie(config-if-VLAN 1)#ip address 10.0.240.254 255.255.255.0   //配置IP地址10.0.240.254子网掩码255.255.255.0
Ruijie(config-if-VLAN 1)#exit   //回到全局配置模式
Ruijie(config)#interface vlan 2    //配置vlan 2
Ruijie(config-if-VLAN 2)#ip address 10.0.241.254 255.255.255.0   //配置IP地址10.0.241.254子网掩码255.255.255.0 
Ruijie(config-if-VLAN 2)#exit   //回到全局配置模式
Ruijie(config)#interface vlan 3    //配置vlan 3
Ruijie(config-if-VLAN 3)#ip address 10.0.242.254 255.255.255.0    //配置IP地址10.0.242.254子网掩码255.255.255.0
Ruijie(config-if-VLAN 3)#exit   //回到全局配置模式
Ruijie(config)#interface vlan 4    //配置vlan 4
Ruijie(config-if-VLAN 4)#ip address 10.0.243.254 255.255.255.0   //配置IP地址10.0.243.254子网掩码255.255.255.0 
Ruijie(config-if-VLAN 4)#end   //回到特权模式
Ruijie#show interfaces status   //显示接口状态信息
Ruijie#show interfaces   //显示接口全部信息
5、管理MAC地址表
Ruijie#configure terminal   //进入全局配置模式
Enter configuration commands, one per line. End with CNTL/Z.
Ruijie(config)#mac-address-table aging-time 1000  //设置地址老化时间为1000秒
Ruijie(config)#no mac-address-table aging-time  //将地址老化时间恢复为缺省值300秒
Ruijie(config)#end   //回到特权模式
Ruijie#show mac-address-table aging-time  //显示当前的地址老化时间
Ruijie#show mac-address-table  //显示所有类型的MAC地址信息(包括动态地址,静态地址和过滤地址)
Ruijie#clear mac-address-table dynamic  //删除设备上所有的动态地址项
Ruijie#clear mac-address-table dynamic interface gigabitethernet 0/27  //删除0/27端口上的所有动态地址表项
Ruijie#clear mac-address-table dynamic vlan 4  //删除VLAN 4上的所有动态地址表项
Ruijie#configure terminal   //进入全局配置模式
Enter configuration commands, one per line. End with CNTL/Z.
Ruijie(config)#mac-address-table static 00d0.f800.073c vlan 2 interface gigabitethernet 0/26 
//增加一个在vlan 2中的将目的mac地址为00d0.f800.073c的包转发到0/26端口上的静态地址表项
Ruijie(config)#no mac-address-table static 00d0.f800.073c vlan 2 interface gigabitethernet 0/26  //删除一个在vlan 2中的将目的mac地址为00d0.f800.073c的包转发到0/26端口上的静态地址表项
Ruijie(config)#mac-address-table filtering 00d0.f808.000c vlan 2  //增加一个在vlan 2中的源mac地址为00d0.f800.000c的过滤地址表项(当设备在该VLAN内收到以这个MAC地址为源地址的包时,这个包都将被直接丢弃)
Ruijie(config)#no mac-address-table filtering 00d0.f808.000c vlan 2   /删除一个在vlan 2中的源mac地址为00d0.f800.000c的过滤地址表项
Ruijie(config)#end   //回到特权模式
Ruijie#show mac-address-table static  //显示所有静态地址信息
Ruijie#show mac-address-table filtering   //显示所有过滤地址信息
Ruijie#show mac-address-table interface gigabitethernet 0/27  //显示0/27端口的所有类型的地址信息
Ruijie#show mac-address-table vlan 2  //显示VLAN 2的所有类型的地址信息
Ruijie#show mac-address-table count  //显示地址表中MAC地址的统计信息
6、配置IP和MAC地址绑定(全局)

Ruijie#show arp  //显示ARP表信息
Ruijie#configure terminal   //进入全局配置模式
Enter configuration commands, one per line. End with CNTL/Z.
Ruijie(config)#address-bind 10.0.240.11 00d0.f800.4251  
//将ip地址10.0.240.11与mac地址00d0.f800.4251进行绑定
Ruijie(config)#address-bind 10.0.240.12 00d0.f800.4252  
//将ip地址10.0.240.12与mac地址00d0.f800.4252进行绑定
……
Ruijie(config)#address-bind uplink gigabitethernet 0/28   //配置0/28端口为地址绑定例外口(注意:交换机上联到路由的端口必须配置为地址绑定例外口)
Ruijie(config)#address-bind uplink fastethernet 0/14  //配置0/14端口为地址绑定例外口
……
Ruijie(config)#address-bind install   //开启绑定生效功能
Ruijie(config)#no address-bind 10.0.240.21 00d0.f800.4253  
//取消ip地址10.0.240.21与mac地址00d0.f800.4253的绑定
……
Ruijie(config)#end   //回到特权模式
Ruijie#show address-bind summary  //显示已绑定的地址数和最大绑定地址数(S3750-24最大绑定地址数为123)以及绑定是否成功的状态
Ruijie#show address-bind   //查看IP和MAC地址绑定表
Ruijie#show address-bind uplink  //查看地址绑定例外口
7、配置端口安全地址(端口)
Ruijie#configure terminal   //进入全局配置模式 
Enter configuration commands, one per line. End with CNTL/Z.
Ruijie(config)#interface fastethernet 0/1
Ruijie(config-if-Fastethernet 0/1)#switchport port-security mac-address 00d0.f800.4254  //配置0/1端口安全地址mac地址00d0.f800.4254
Ruijie(config-if-Fastethernet 0/1)#switchport port-security mac-address 00d0.f800.4255  //配置0/1端口安全地址mac地址00d0.f800.4255
Ruijie(config-if-Fastethernet 0/1)#no switchport port-security mac-address 00d0.f800.4254  //删除0/1端口安全地址mac地址00d0.f800.4254
Ruijie(config-if-Fastethernet 0/1)#switchport port-security   //启用0/1端口安全
Ruijie(config-if-Fastethernet 0/1)#no switchport port-security   //关闭0/1端口安全
Ruijie(config-if-Fastethernet 0/1)#exit   //回到全局配置模式
Ruijie(config)#interface fastethernet 0/20
Ruijie(config-if-Fastethernet 0/20)#switchport port-security ip-address 10.0.240.11  //配置0/21端口安全地址IP地址10.0.240.11
Ruijie(config-if-Fastethernet 0/20)#switchport port-security ip-address 10.0.240.12 
 //配置0/21端口安全地址IP地址10.0.240.12
Ruijie(config-if-Fastethernet 0/20)#no switchport port-security ip-address 10.0.240.11  //删除0/21端口安全地址IP地址10.0.240.11
Ruijie(config-if-Fastethernet 0/20)#switchport port-security   //启用0/20端口安全
Ruijie(config-if-Fastethernet 0/20)#exit   //回到全局配置模式
Ruijie(config)#interface fastethernet 0/21
Ruijie(config-if-Fastethernet 0/21)#switchport port-security mac-address
00d0.f800.4251 ip-address 10.0.240.11  //配置0/21端口安全地址mac地址00d0.f800.4251,并绑定IP地址10.0.240.11
Ruijie(config-if-Fastethernet 0/21)#switchport port-security mac-address 00d0.f800.4252 ip-address 10.0.240.12 
 //配置0/21端口安全地址mac地址00d0.f800.4252,并绑定IP地址10.0.240.12
Ruijie(config-if-Fastethernet 0/21)#no switchport port-security mac-address 00d0.f800.4251 ip-address 10.0.240.11  //删除0/21端口安全地址mac地址00d0.f800.4251
Ruijie(config-if-Fastethernet 0/21)#switchport port-security   //启用0/21端口安全
Ruijie(config-if-Fastethernet 0/21)#switchport port-security maximum 60  //配置0/21端口上安全地址的最大个数为60,范围是1-1000,缺省值为128
Ruijie(config-if-Fastethernet 0/21)#no switchport port-security maximum  //恢复安全地址数为缺省值
Ruijie(config-if-Fastethernet 0/21)#end  //回到特权模式
Ruijie#show port-security  //显示所有安全端口的统计信息
Ruijie#show port-security interface fastethernet 0/1  //查看0/1接口的安全配置信息
Ruijie#show port-security address  //显示所有安全地址信息
Ruijie#show port-security address interface fastethernet 0/1  //查看0/1接口的安全地址信息

三、配置路由
Ruijie#configure terminal   //进入全局配置模式
Enter configuration commands, one per line. End with CNTL/Z.
Ruijie(config)#ip route 0.0.0.0 0.0.0.0 10.1.252.25   //配置网络地址为0.0.0.0 子网掩码为0.0.0.0 下一跳地址为10.1.252.25(路由器连接交换机的端口地址)的静态路由作为缺省路由
Ruijie(config)#end   //回到特权模式
Ruijie#show ip route   //显示路由信息

四、配置DHCP服务(可选)
    锐捷S3750系列交换机支持DHCP服务和DHCP中继服务,可将交换机配置成DHCP服务器,也可启用DHCP中继服务使用其他设备(路由器或DHCP服务器)上的DHCP服务。
    这里将交换机配置成DHCP服务器
Ruijie#configure terminal   //进入全局配置模式
Enter configuration commands, one per line. End with CNTL/Z.
Ruijie(config)#service dhcp   //启用DHCP服务
Ruijie(config)#ip dhcp excluded-address 10.0.241.1 10.0.241.10   //配置DHCP排斥地址10.0.241.1至10.0.241.10
Ruijie(config)#ip dhcp excluded-address 10.0.242.201 10.0.242.253   //配置DHCP排斥地址10.0.242.201至10.0.241.253
Ruijie(config)#ip dhcp pool vlan0002   //配置地址池名为vlan0002
Ruijie(dhcp-config)#network 10.0.241.0 255.255.255.0   //配置地址池的网络号10.0.241.0和子网掩码255.255.255.0
Ruijie(dhcp-config)#default-router 10.0.241.254   //配置客户端的缺省网关10.0.241.254
Ruijie(dhcp-config)#dns-server 218.201.21.132 218.201.4.3   //配置客户端可用的DNS服务器地址218.201.21.132和218.201.4.3
Ruijie(dhcp-config)#lease 180   //配置客户端IP地址的租期为180天(为infinite时表示无限期)
Ruijie(dhcp-config)#exit   //回到全局配置模式
Ruijie(config)#ip dhcp pool vlan0003   //配置地址池名为vlan0003
Ruijie(dhcp-config)#network 10.0.242.0 255.255.255.0   //配置地址池的网络号10.0.242.0和子网掩码255.255.255.0
Ruijie(dhcp-config)#default-router 10.0.242.254   //配置客户端的缺省网关10.0.242.254
Ruijie(dhcp-config)#dns-server 218.201.21.132 218.201.4.3   //配置客户端可用的DNS服务器地址218.201.21.132和218.201.4.3
Ruijie(dhcp-config)#lease 180   //配置客户端IP地址的租期为180天(为infinite时表示无限期)
Ruijie(dhcp-config)#end   //回到特权模式
Ruijie#show ip dhcp server statistics   //显示DHCP服务器统计信息
    如果
使用DHCP中继服务
Ruijie#configure terminal   //进入全局配置模式
Enter configuration commands, one per line. End with CNTL/Z.
Ruijie(config)#service dhcp   //启用DHCP中继服务
Ruijie(config)#ip helper-address 10.1.252.25   //配置全局的DHCP服务器IP地址
Ruijie(config)#end   //回到特权模式
Ruijie#show running-config   //显示当前交换机配置信息
Ruijie#copy running-config startup-config   //保存当前配置到启动配置文件
Ruijie#reload   //重新启动交换机

五、备份和恢复配置文件
在本地计算机上启动tftp服务器(IP地址为10.0.240.81)
启动命令提示符
C:\Windows\system32>telnet 10.0.240.254
Trying 10.0.240.254 ... Open
User Access Verification   //进入远程设备的登录界面
Password:      //输入用户口令
Ruijie>enable   //进入特权模式
Password:      //输入特权模式口令
Ruijie#dir   //显示flash中文件和目录信息
Ruijie#copy flash:config.text tftp://10.0.240.81/config.bak   //将配置文件备份到本地计算机中命名为config.bak
Ruijie#del config.text   //删除当前配置文件
Ruijie#copy tftp://10.0.240.81/config.bak flash:config.text   //将配置文件从本地计算机恢复到系统中
Ruijie#copy flash:config.text flash:config.bak   //将配置文件备份到flash中命名为config.bak
Ruijie#

  评论这张
 
阅读(20141)| 评论(3)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017